Функция СУММЕСЛИ в Excel: примеры использования

Однажды жизненные обстоятельства заставляют осваивать новые программные инструменты для решения повседневных или офисных задач. Вручную выполнять долго и неудобно, к тому же увеличивается вероятность совершить ошибку. Поэтому рассмотрим, как работает СУММЕСЛИ в Excel и покажем примеры использования.

Офис в Windows 10 Mobile

Синтаксис функции и принцип работы

О возможностях сложения известно каждому пользователю, хоть раз запускавшего Excel. СУММЕСЛИ – логичное продолжение базовой СУММ, отличие которой заключается в суммировании по условию.

Синтаксис СУММЕСЛИ выглядит следующим образом:

=СУММЕСЛИ(диапазон; критерий; [диапазон суммирования]), где:

  • диапазон – список значений, к которым будет применено ограничение;
  • критерий – конкретное условие;
  • диапазон суммирования – список значений, которые будут суммироваться.

Итак, имеем функцию с тремя компонентами. Стоит отметить, что последний аргумент можно не использовать – СУММЕСЛИ способен работать без диапазона суммирования.

Совет! Рекомендуем ознакомиться со статьей: «Исправление ошибки «Закладка не определена» в Word».

Примеры использования

Рассмотрим все возможные ситуации применения одноименной функции.

Общий вид

Разберем простой пример, призванный наглядно показать преимущества использования СУММЕСЛИ.

Есть таблица, в которой указаны порядковый номер, вид товара, наименование, цена за единицу и количество штук на складе.

Допустим, нам нужно выяснить, сколько всего единиц товара находится на складе. Тут все просто – используем СУММ и указываем нужный интервал. Но что делать, если интересует количество единиц одежды? Тут на помощь и приходит СУММЕСЛИ. Функция будет иметь следующий вид:

=СУММЕСЛИ(C3:C12;»одежда»;F3:F12), где:

  • C3:C12 – тип одежды;
  • «одежда» – критерий;
  • F3:F12 – интервал суммирования.

Общий вид функции СУММЕСЛИ
В результате получили 180. Функция проработала все указанные нами условия и выдала корректный результат. Также можно повторить подобные манипуляции для других типов товара, сменив критерий «одежда» на какой-то другой.

С несколькими условиями

Этот вариант нам нужен в тех случаях, когда кроме одежды нас интересует еще и стоимость единицы товара. Т.е. кроме одного условия можно использовать два и более. В данном случае нам нужно прописать немного измененную функцию – СУММЕСЛИМН. Суффикс МН означает множество условий (минимум 2), которые мы вам сейчас продемонстрируем. Функция будет иметь вид:

=СУММЕСЛИМН(F3:F12;C3:C12;»одежда»;E3:E12;50), где:

  • F3:F12 – диапазон суммирования;
  • «одежда» и 50 – критерии;
  • C3:C12 и E3:E12 – диапазоны типов товара и стоимости единицы соответственно.

СУММЕСЛИМН (с несколькими условиями)

Внимание! В функции СУММЕСЛИМН аргумент диапазона суммирования стоит в начале формулы. Будьте внимательны!

С динамическим условием

Бывают ситуации, когда мы забыли внести один из товаров в таблицу и его нужно добавить. Спасает ситуацию тот факт, что функции СУММЕСЛИ и СУММЕСЛИМН автоматически подстраиваются под изменение данных в таблице и мгновенно обновляют итоговое значение.

Для вставки новой строки нужно нажать ПКМ на интересующей ячейке и выбрать «Вставить» – «Строку».
Добавление строки

Далее просто введите новые данные или скопируйте их с другого места. Итоговое значение соответственно изменится. Аналогичные трансформации происходят и при редактировании или удалении строк.
Адаптивное изменение результатов

На этом я заканчиваю. Вы увидели основные примеры использования функции СУММЕСЛИ в Excel. Если есть какие-то рекомендации или вопросы – милости прошу в комментарии.

Хороший сайт? Может подписаться?

Рассылка новостей из мира IT, полезных компьютерных трюков, интересных и познавательных статей. Всем подписчикам бесплатная компьютерная помощь.

Комментарии